OpenVPN: DNS-Probleme und Verbindung langsam nach Creators Update

OpenVPN

Wer die Software zum Aufbau eines virtuellen, privaten Netzwerkes verwendet und zeitgleich das Windows 10 Fall Creators Update installiert hat, kann vor einem ziemlich nervigen Problem stehen.

Das Windows 10 Fall Creators Update wurde bereits schon am 17. Oktober 2017 für alle ausgerollt und bringt Fehlerbehebungen, Neuerungen sowie Verbesserungen des Betriebssystems mit sich. Bisher sind keine große, nennenswerte Komplikationen aufgetreten.


Seit einiger Zeit bemerkte ich aber, dass meine OpenVPN-Verbindung ziemlich langsam und unzuverlässig geworden ist. Der Verbindungsaufbau einer Webseite dauerte mit einer bestehenden Verbindung immer einige Sekunden. Trennte ich die Verbindung, lud die Seite wie gewohnt sehr flott.

Lange war ich auf der Suche und habe es sogar in Erwähnung gezogen, den Rechner (die Festplatte) zu formatieren und Windows komplett neu aufzuspielen. Da mir so ziemlich alle Lösungsansätze ausgingen, hatte ich das auch getan.

Da es aber danach immer noch nicht besser wurde, suchte ich weiter nach einer Lösung und beschäftigte mich genauer damit, wo eigentlich das Problem liegt. Im späteren Verlauf stellte ich dann fest, dass die Auflösung einer Domain die Ursache dafür ist, sodass der Aufbau einer Seite so lange dauert. Also liegt hier irgendein DNS-Problem vor. Per OpenVPN hatte ich dann auch einen anderen DNS-Server verwendet, aber auch das brachte keine Lösung.


Später sah ich dann immer wieder die Meldung „block-outside-dns“ im OpenVPN-Log, welche bezweckt, dass der von Windows konfigurierte DNS-Server geblockt und der eigen eingestellte Server verwendet wird. Das soll sogenannte „DNS-Leaks“ verhindern und die Anonymität erhöhen.

Im Anschluss hatte ich über den Netzwerkeinstellungen die Schnittstellenmetrik auf „1“ gesetzt und siehe da, das Problem war behoben. Jede Webseite lud wieder wie gewohnt, kein langes Warten, bis der Host (die Domain) aufgelöst wurde (in eine IP-Adresse) und/oder ähnlicheres mehr.

Dazu gibt man in der Startleiste (Windows-Taste drücken) „Netzwerk- und Freigabecenter“ ein (Systemsteuerung\Netzwerk und Internet\Netzwerk- und Freigabecenter) und klickt anschließend bei einer bestehenden OpenVPN-Verbindung auf das entsprechende Netzwerk.


Im Anschluss öffnet sich ein Pop-up, wo ihr im Anschluss auf „Eigenschaften“ klickt. In dem neuen Pop-up doppelklickt ihr anschließend auf „Internetprotokoll, Version 4 (TCP/IPv4)“, in dem neuen Pop-up unten rechts auf „Erweitert“ und zum Schluss nimmt man das Häkchen bei „Automatische Metrik“ raus und setzt unten den Wert „1“ ein.

Hat man das IPv6-Protokoll ebenfalls aktiviert, kann hier auch die entsprechende Änderung vornehmen. In meinem Fall habe ich IPv6 aber deaktiviert, sodass ich über OpenVPN immer mit einer IPv4-Adresse im Internet unterwegs bin.

Das Problem zeigt sich hier ausschließlich mit der neuen Fall Creators Update-Version. Aktuell verwende ich die Windows Version 1709 mit dem Betriebssystembuild 16299.19. Wenn ihr demnach auch von dem Problem betroffen seid, habt ihr hier nun die passende Lösung dazu.


Nachtrag vom 02. November 2017:
Sollte das nichts bringen, kann versuchen, die Windows Firewall auf „Standard“ zurückzusetzen.

Das könnte dich auch interessieren:

Raphael Jäger

Veröffentlicht von

Raphael ist Redakteur und Inhaber von Gedankenausbruch.com. Bei Anregungen, Fragen oder Problemen gerne und zu jeder Zeit erreichbar. Wenn du zum Beitrag eine Frage hast, veröffentliche einfach ein Kommentar. Per E-Mail, sowie per Smartphone-Push-Benachrichtigung werden wir darüber informiert und werden zeitnah auf den Kommentar antworten.

4 Kommentare » Schreibe einen Kommentar

  1. Hi, also als erstes ist es das „Fall Creators Update“ – 1709 nicht Creators Update – 1704. Wenn man OpenVPN komplett deinstalliert, reboot und dann die Neuinstallation vornimmt funktioniert es auch wieder wie vorher.

    • Raphael Jäger

      Bei mir nicht. Auch der Wechsel auf den neuen TAP-Treiber brachte nichts. Lediglich die Metrik-Änderung brachte bei mir den erhofften Erfolg.

  2. Oft liegen solche Probleme auch an veralteten Treibern/Software
    die eingesetzte Version wurde leider oben nicht angegeben bzw. ob zuvor ein Update erfolgt ist

    • Raphael Jäger

      Ja, zuvor hatte ich eine dezent alte OpenVPN-Version in Verwendung gehabt, aber auch mit der neuesten Version (plus neuester TAP-Treiber) ging das Problem nicht weg.

      Ich hatte vorher die Version „OpenVPN 2.2.2 Win32-MSVC++ [SSL] [LZO2] [PKCS11] built on Dec 15 2011“ mit der TAP-Version 9.9.2 und jetzt die Version „OpenVPN 2.3.18 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [IPv6] built on Sep 26 2017“ mit der TAP-Version 9.21.2.

      Aber bei beiden Versionen ist das Problem hier mit dem Creators Update festzustellen, sobald die Metrik nicht auf „1“ gesetzt ist.

Schreibe einen Kommentar

Pflichtfelder sind mit * markiert.